Release Notes - Quantrix Modeler

To view these release notes with live links, and/or to see prior versions of Release Notes, view them at the Quantrix web site

Quantrix Modeler 22.2.0

 

Improvements in Modeler Version 22.2.0

Quantrix is pleased to introduce major usability improvements in 22.2.0.

The Quantrix Modeler update process includes a major improvement with 22.2.0: Update checks will automatically and seamlessly check the Enterprise Qloud server version using your Qloud URL, and will only update Modeler if your Qloud version is compatible (QM-24265). The new update process resolves the scenario where users update Modeler and then receive a message that the Modeler and Qloud versions are not compatible. In the case where the Qloud URL cannot be reached or does not support the update URL, it will attempt to use the legacy update URL to process updates.

If your Mac device has the Apple-designed M1 chip, you can use the new macOS Modeler installer (the new installer will not run for Macs that use an Intel/AMD chip) (QM-24834).

Item Filters

A new and powerful feature, the Item Filter, lets you quickly search, hide, and show, items or groups on a category (QM-24814). This filter control is complementary to the existing filter capabilities, which are now re-named Cell Filters, where their respective names indicate the type of object to be filtered.

The Item Filter icon displays on a category when you hover over it, and when clicked, pops up the new item filter tree. In the tree, you can collapse and expand groups and check or un-check items to hide them from the active view. Items filtered in this way will only be hidden in the current view: other views, including those with a linked category, will not be filtered.

If items have been filtered, the filter symbol remains visible on the category tile, and also appears in the view tab and model browser. If no items are filtered, the filter symbol is visible only on hover. Please note this “filtered” symbol replaces the collapse symbol and is shown when items or groups are hidden, collapsed or filtered (QM-24863). Note that Collapse actions are still available and haven't changed: only the symbol used to represent collapsed data has changed to make the meaning more clear.

Using search in combination with grouped check boxes in the item filter tree can easily hide a large number of items or groups that match a pattern. Simply type the pattern to match item or group names, then uncheck a box in the tree (including the top most check box if desired) to hide only the matched items below that level in the tree. This results in only unmatched items being displayed.
Item filters can be used in any axis of any view, including views, charts, canvases and in filter trays, provided the user has filter & sort permissions. If a filtered category is placed in the filter tray or filtered while in the tray, the effect is to remove the available selections in the drop down list.

To dismiss the item filter tree and keep your changes, click anywhere outside it. To dismiss and discard your most recent changes, use the escape key from within the tree, or use Undo outside the tree.


It is now possible to filter selected items in the right-click context menu. A new Filter Items option allowing you to Hide Selected, Hide Unselected, and, provided an Item Filter is already applied, Reset Filter (QM-24906).
See image below. Items or groups filtered in this ad hoc way can also be inspected and managed in the Item Filter tree.

Some Data menu options and right-click item filter context menu options, related tooltips and action names have been updated to better differentiate the several filter features that Modeler offers (such as the data import filter, category item filter and filter tray filter) (QM-24874). Some related right-click menus have been condensed and rearranged, with their action titles improved for clarity and ease of use. For example, with an item selected, the right-click action name is Filter Cells and the filter cells pane that displays when you select Filter Cells is titled Edit Cell Filter.

Below shows some options from a right-click item context menu:

An improvement to categories is that the category tile format and category Item Filter are included when you drag and drop a category on a new matrix to link, copy or replace a category (QM-24878). Note that although Item Filters are copied when the category is initially moved, as mentioned above, they are independent for each view. Note also that if you use the right-click context menu from a category to Copy, the category tile format and filter are not copied. 

Some Data menu options and right-click item filter context menu options, related tooltips and action names have been updated to better differentiate the several filter features that Modeler offers (such as the data import filter, category item filter and filter tray filter) (QM-24874). Some related right-click menus have been condensed and rearranged, with their action titles improved for clarity and ease of use. For example, with an item selected, the right-click action name is Filter Cells and the filter cells pane that displays when you select Filter Cells is titled Edit Cell Filter.

 

Smart Buttons for Canvas Navigation and Update Data Import(s)

Quantrix Modeler 22.2.0 includes new “smart buttons”, that will reduce the time to build model-based applications. (QM-24872). In canvas layout mode, when you click the Add Scripted Button on the Canvas toolbar, the Edit Button dialog now includes new pre-configured options for canvas navigation and updating data imports. These smart buttons do not require the user to write scripts, but the Custom Script > Script Button is still available if you want to write buttons with custom scripts.
The smart buttons are described below.

Canvas Navigation Smart Buttons
App builders can place preconfigured buttons on the canvas that allow a user to navigate to the Next, Previous or a specific canvas. The order and organization of canvases in the Model Browser determines the meaning of “next” and “previous”. If canvases with navigation buttons are in a folder, the nav buttons will move from the active canvas to the next and previous in the model browser folder list, but will not exit that folder. If an app builder re-orders the canvases, the smart buttons will update themselves to use the new order without modification.
The “Open Canvas” button can navigate to any canvas, including ones not in a given folder. App builders can use this to create branching scenarios that might move from one folder to the next, where next and previous buttons navigate only within the current folder.
Note that these buttons have the additional behavior that they close all other views (but not tool panes), making the application experience immersive and distraction-free. It is still possible to create a button that opens a perspective or opens a specific view, but keep in mind that those will be closed when the next smart button is pressed. It is also still possible to give users permission to perspectives for ad hoc access to model components as before.

Data Import Smart Buttons
App builders can place buttons that refresh all or selected matrices based on data imports (QM-24700). Importantly, the user can select if those updates should use Embedded Credentials (as might be used for a service account based import) or not, which would either use a local credential if the app is used in Modeler, or prompt users for credentials, whether that be user/password or OAuth credentials, for e.g. Salesforce. Note that if “use embedded” is selected, but no embedded credentials exist, the query will fail.


Please see the Smart Buttons & Scripted Buttons help topic for further details, including smart button usage notes.

 

If developers want to write their own navigation scripts rather than use the "pre-built" smart buttons, they can use the same methods used by the smart buttons (QM-24870).

For navigation, these methods include the following:
nextPresentation(), previousPresentation(), closeAllViews() and closeAllToolPanes() and an additional |MyMatrix|.bringToFront() method.

For refreshing data imports, these methods include the following:
void updateSelectedImportMatrices(Collection<Matrix> importMatrices)

Update a collection of import matrices and refresh all their sources. This will handle ordering the imports and refreshes to ensure that each refresh happens only once and any imports that depend on others will be updated later. If there are calculations involved as well, that will not be taken into account and must be handled manually instead. This requires appropriate permissions and authentication (see performWithEmbeddedCredentials()).

Another feature supports canvas navigation from within scripting: you can now select a matrix view from a
canvas using pipe selection on the matrix name, get a list of canvas objects from a canvas, and select cells,
nodes, ranges, and item descriptors using extended pipe selection from a matrix canvas object (QM-24871).
For example,
|Canvas1::Matrix1::A1|.backgroundColor = "FF0000"
alert(|Canvas1::Matrix1|)
|Canvas1::Rectangle2|.text = "{Matrix1::A1}"
|Matrix1|.filterTrayCategories.add(|Matrix1::A|)
|Canvas1|.filterTrayCategories.add(|Matrix1::A|)

Pasting a copied canvas object is improved regarding the pasted location (QM-24911). The copied object is placed using an offset location from the original to make it easier to detect when it makes sense, such as when you copy and paste an object into the same canvas. When you paste into a different canvas, the offset isn't used which makes it easier to create consistent canvases. When copying and pasting objects from a group to a canvas or to a group of a different size, Modeler applies the offset if indicated, and places the paste optimally for current and potentially subsequent pastes.

There is now a new Boolean input type as configured in Constrained Inputs (QM-24373)
In Data > Constrain Input > Boolean when you choose a cell or item(s) and select Boolean constraint the new Boolean options appear:

Users can choose the type of input for the constrained input cell, including the new checkbox method, which allows for fast toggle of the value. Other common Boolean inputs such as “yes/no” etc. plus custom values will show the user a drop down list with those choices. For the check box, users can choose to show the boxes at all times or only on hover, for a cleaner appearance. Boolean constrained inputs can also be based on a formula that resolves to a Boolean but it cannot be empty.
Please read more details about the Boolean constrained input in the Constrain Input help topic and please see the related check box known issue.

There is also an improved boolean format, which is distinct from the boolean constraints above (QM-24840). In the Format Toolbox, boolean has been moved from its former location under the Number Format > Special drop-down list to be a top-level number format selection.

Cells formatted as boolean in this way will display as TRUE or FALSE, where 0 is false, any other number is TRUE, and other text is ignored except that you can directly type true or false in a cell to set the boolean format automatically for that cell. Models containing cells with Number Format > Special > Boolean are converted to Number Format > Boolean.

Important Note: Models containing the new boolean format or the new Boolean constrained input will not open in older versions of Modeler.


All cell formatting actions (for example, font styles, number formats, colors) that you make using the top level menu, the toolbar, right-click, or format toolbox, now include a Cancel button on the progress panel to roll back the formatting action in progress (QM-24839).


The canvas toolbar displays only if the user has permissions to lay out the canvas (QM-24274). This improvement eliminates potential confusion for users who don't have canvas layout permissions, and it results in a larger viewing area in interaction mode.

Signing into Salesforce using OAuth is now possible in addition to the previous method of signing in with a user name and password (QM-24580). This capability is distinct from Single Sign-On, but related. It is common that when an organization configures their Salesforce domain to use SSO (for example with Azure AD), they might also disable username and password access. Such a configuration would then make OAuth the only allowed method of connecting to Salesforce data. If the Salesforce instance does still allow username and password access, Quantrix can use either authentication method, which can be especially useful for service accounts using embedded credentials in a script. However, the older method is restricted to query Salesforce table objects.


The new Salesforce access via OAuth allows importing Salesforce reports (which are distinct from Salesforce Tables and other objects) (QM-24098). In Data Import > Salesforce you can now select from a list of recently accessed reports in addition to the raw tables. This list can contain up to 200 reports, and can import the data on either a detailed or aggregate level depending on the type of report. The imported data is displays in the Data Import data tree as usual for further configuration. Please note that a user must actually access a report while in Salesforce for it to appear in the recently accessed list! Quantrix does not support Multi-block report formats.


A new Data Import feature lets Modeler users with Data Import permissions hover over any Data Import on the data matrix tab, or in the Data Browser over the query, to see the date last updated once the import has been initially populated or updated (QM-24698).
You can also use a new scripting method, matrix.lastUpdated(), to return the date last updated using a script.

Performance is improved when selecting a large number of cells (many thousands) and changing cell formats, in a large sorted matrix with multiple categories (QM-24460).

Calculation script methods have been consolidated and replaced by one new calculation script method, calculateNow() (QM-24809). Calculation is always turned off during the execution of a script and is automatically triggered if needed when the script finishes, so calculateNow() is needed only if the remainder of the script itself needs the newly calculated values. calculateNow() always refreshes intermodel formulas.

To reduce confusion and promote the use of improved methods, deprecated methods such as refreshAllDataImports(), performWithAuthentication(), recalculate(), recalculateAll(), ensureCalculated() and potentially others will no longer be displayed in scripting's context-sensitive autocomplete help (QM-24838). Scripts containing these methods will still function correctly. 

The documentation for using performWithEmbeddedCredentials() in scripts has been improved both at the online scripting reference, https://quantrix.com/help/scripting/index.html, and in the Scripting Examples webhelp (QM-24807).

A formula usability improvement allows you to write a recursion formula for categories more easily (QM-24829). Any category name you enter on a new formula line followed by an equals sign is interpreted as the beginning of a recursion formula (i.e., Modeler interprets "CategoryName =", as CategoryName[THIS]). You don't need to enter [THIS].
Simply add the recursion statement on the right side of the equals sign. For example, CategoryName = CategoryName[PREV] + 100, or Quarter = Quarter[PREV] + 100.

A usability enhancement allows you to fill cells using a formula, and then delete the formula without deleting the cell values, leaving editable input cells (QM-24761). Access this feature by right-clicking in the formula line (or select multiple formula lines and right-click). From the right-click context menu, choose Delete without Clearing (note the hover text for the option: "Delete formula(s) leaving previously calculated values in cells"). Or, you can use Ctrl-delete or Ctrl-backspace to do the delete from the formula line(s). See Managing Formula Fields.

 

Significant Fixes in Modeler Version 22.2.0

Exceptions no longer sometimes occur when in line-drawing mode on a canvas (QM-20249, QM-24689)

When using the French translation pack an error no longer occurs when publishing to Qloud (QM-24886, F0133565)

Exceptions no longer occur in certain scenarios when using Bulletins (QM-24813)

An exception related to pasting formatted text into a canvas text box should no longer occur (QM-22685)

During Data Import, the import location range is no longer cleared after moving a cell when there is no data item or category in the import matrix (QM-24799, F0132344)

A Query Failed error no longer occurs in a data import that has union categories when you try to drill down in a data import matrix to see data, create matrices or create a data source (QM-24833)

Disconnect from Data Source disconnects data import matrices with union categories correctly: the matrix is disconnected from the data source, and the data import matrix changes into a regular matrix (QM-24754)

If models with scripted buttons were opened in some previous Modeler versions, the buttons assigned to the default button color now correctly use the default color (QM-24788)
Please see related Known Issue below, (QM-24854)

Items and groups can now be selected by clicking from the right side of the group/item when the summarization button isn't present (QM-24866, F0132804)

Cells in a matrix or in a matrix on a canvas now auto-resize correctly when using double-click (QM-24560)

When using embedded credentials (for authentication in scripts) from Credentials Manager within Qloud via scripted buttons, embedded credentials errors no longer occur (QM-24891, F0133034)

A cell number format entered with more than 2 digits after the decimal point no longer causes the entry to change to 2 digits after the decimal point (QM-24951)

Known Issues in Modeler Version 22.2.0

The Constrain Input Boolean checkbox behavior in matrices is not consistent with canvas check boxes regarding empty cells and non-numeric cells and whether the check boxes appear selected (QM-24854).

Qloud users of version 21.2.2 and 22.1.2 whose canvas button backgrounds were set to transparent have those backgrounds reset to the default button color (QM-24788). If you set the button color back to transparent, it remains transparent.

Currently, Salesforce Multi-block Reports are not supported in Salesforce data imports (QM-24938). If you select a Salesforce report that is multi-block, a message displays explaining that the multi-block format is not supported.

Previous Release Notes

Quantrix Modeler 22.1.2

Important Note for users on older Modeler versions (version 6 & earlier): 

In the 18.x releases of Quantrix Modeler, we switched to a new serial number scheme. In order to smooth the transition, we continued to support version 6 and prior serial numbers. We have removed this legacy support in version 22.1.2. This means if you have a very old serial number that you have been carrying forward, it will no longer be recognized, and you will need to have a modern serial issued to activate your licenses. If you have this or any problems activating your subscription, email customerservice@quantrix.com who can help with this quick process.

Important Note for Data Import users of Oracle 11 and earlier versions: 

Oracle dropped extended support for their database version 11 at the end of 2020. As some of our customers still use this version, we have continued support for it. However, our new Max Rows feature takes advantage of SQL syntax only available in modern versions of Oracle db: therefore, if your organization would like to continue using Oracle 11 or earlier, you must add the following property in the Quantrix Modeler vmoptions file: 

-Dquantrix.data.useLegacyOracleSyntax=true

Adding this property allows you to use Oracle 11 but prevents you from using the Data Import Max Rows feature. We strongly advise that you transition to a more modern version of Oracle as soon as possible.

Improvements in Version 22.1.2

Quantrix Qloud 22.1.0 supports Single Sign on (QM-24680). If SSO has been configured on your Qloud server, users can authenticate and directly access models on your Qloud leveraging a third party identity provider, and Quantrix Modeler will also use SSO to access your Qloud for Sign-in, and to Publish and check in/out models. The first time that authorization is requested (i.e., when Modeler needs access to Qloud resources) you will be prompted to accept or deny authorization. Provided you accept, you won’t be prompted about Qloud access again unless the SSO security token is revoked or you log out of Qloud from Modeler. Please read Single Sign-on and Workflow details in Qloud help and take note of the related Known Issue below regarding the Safari browser.

Some of our customers have grouped hierarchies or categories with many thousands of items, which can make model navigation cumbersome. Quantrix Modeler includes a new feature called “Summarize”, that allows users to quickly “roll up/down” one or many eligible items, including those within Timelines (QM-24574, QM-24598). Summarize will hide or unhide individual items and create a new (or keep existing) Summary Item(s) in their place. To Summarize, hover over a top-level item or group on the column or row axis. Provided your role has expand/collapse and formula permissions, eligible items and groups will show a Summarize button which, when clicked, will perform the above actions. Summarize uses standard sum(summary()) formulas, which can be edited like any other formula, for example to modify it to be an average() rather than sum as needed for different types of data.

Summarize includes support for shortcut keys, where Ctrl+ or Cmd+Summarize will summarize all peers (all items at the same level), and Shift+Summarize will summarize all children (all items one level below). Use the same shortcut keys with Unsummarize. You can read the Quick Summarization help topic to understand the details, and see the related Options/Preferences for matrices.

When viewing the release notes from Webhelp, to replay the animated gif in Chrome, Edge or Safari refresh the browser. To replay an animated gif in Firefox, press Ctrl (or Cmd) + Shift + F5.

Two new Options/Preferences support the new Summarization feature: Enable Summarization and Create summary formulas in linked matrices. These can be found in the Tools > Options/Preferences > Matrix dialog.

Summarization can be completely disabled by unchecking the “Enable Summarization” option (QM-24649).

The default behavior of Summarize is to create summary formulas in linked matrices in addition to the active one. This behavior may not be desirable, so you can turn it off by unchecking the “Create summary formulas in linked matrices” preference. (QM-24640).

A new feature, Credentials Manager, along with a companion script method described below, allows only users with the Modeler role to create and manage authentication information for data operations and scripts in one location from Tools > Credentials Manager (QM-22515). The Credentials Manager tool is disabled for other roles. Using Credentials Manager ensures that credentials are encrypted, cannot be exposed, and don't need to be re-entered. Credentials Manager allows modelers to easily see all of their locally stored credentials, create and edit those credentials and embed credentials into models where they can be called by scripts. Data operations that require credentials including JDBC URL data connections and Qloud URLs will appear in Credentials Manager.

Users commonly refresh data in a model using a scripted button that calls the performWithAuthentication method. We are deprecating this method (existing instances will still work but we advise you to stop using it) because we have replaced it with a new method, performWithEmbeddedCredentials. The former method required credentials to be included in the script code, making it difficult to reuse credentials in different models. The former method also allowed you to refresh only one data source per script line, making the refresh tasks more difficult to manage. The new method requires no parameters, and behind the scenes the Credentials Manager matches the appropriate credentials to that data source and uses them automatically.

Scripts that use the new performWithEmbeddedCredentials script method allow you to share a model with a Qloud user who can run the script without having to enter credentials.
The performWithEmbeddedCredentials method works for any Data integration that needs credentials.
Scripts containing performWithAuthentication, which is no longer available going forward, still run.

This version also introduces two new methods that take advantage of stored credentials to publish a model to the Qloud (QM-24648). To be used with performWithEmbeddedCredentials, the two new publish methods are:

toServer() - This publishes the target model to the server at the base URL defined in the publisher preferences (Tools > Options/Preferences > Qloud Server URL) and authenticates to the server using stored credentials.
toServer(String url) - This publishes the target model to the server at a specified url that you specify using the method, and authenticates to the server using stored credentials.

Note that two older publish methods have been deprecated and are so noted in the scripting help description.

The two deprecated methods are:
toServer(String username, String password)
toServer(String url, String username, String password)
 

Salesforce credentials are no longer stored in Options/Preferences but instead are entered or updated in the dialogs for Data Import and DataLink (QM-20583). Provided you elect to save the Authentication Information, the credentials can be updated in the Credentials Manager. For Salesforce credentials the value in the password field should be entered as “password[space]token".

You can now enter a default custom instance URL for Salesforce in Tools > Options/Preferences > Data > Salesforce (QM-19882). The tooltip for this option describes the expected URL format. If you have entered a default custom instance URL option, it will appear in the Data Import or DataLink dialog when you choose the Custom Instance radio button option, where it will show the data API appended to the URL. You can override your default by typing a new custom instance URL, but be careful to use the fully specified API url.

A new script method, updateAllDataImportMatrices() allows you to use scripting to update either all data imports or to update only a specified data source (QM-23567, F0099766). The former script method, refreshAllDataImportMatrices() has been deprecated.
updateAllDataImportMatrices(String dataSourceName) lets you refresh a data source you specify and update all of its associated matrices. When used with no arguments, i.e., updateAllDataImportMatrices() the script refreshes every data source and updates all import matrices (like the now-deprecated refreshAllDataImportMatrices()).
The new script method works on Modeler and Qloud, and you can use it in conjunction with performWithEmbeddedCredentials().

When you add a scripted button on a canvas, the Edit Button dialog now lets you create your own button label if desired (QM-24314)

Usability improvements have been added to Date Binning on the Configure Dimension dialog for Dates  (QM-24704):

  • Binned categories are now named according to the overall time bin: Year, Month, Day. For example, if you choose Short Month Name in the dialog, the resulting category will be named "Month".
  • The label for the date format choices has been changed from “Display As” to “Format As”, reflecting this change in behavior.
  • The Short Month Name is now the default for new date categories

For improved usability, Data Import's Google Sheets now defaults to the commonly used option to "Use first row as headers" on new Google Sheets Data Imports, meaning column headers will be based on field names (QM-24528). Previous Sheets imports are unchanged with respect to this setting.

For improved usability, in Import Data, if you choose to put data into an existing matrix and show the configure into matrix dialog as show below, the data type icon displays after you choose fields (QM-24422):

 

 

Data Import now sorts mixed data for groups and items, such as months (names or numerical) and mixed numerical text, correctly (QM-23064)

In Data Import, with the Data Browser open, you can double-click on a data matrix icon to open it provided you have permissions (QM-24728).

If the data matrix is already open but is behind another tab, a single-click on the data matrix icon brings it to the front. 

Data Import has configuration options for what to do when items and data currently in the matrix are no longer present in refreshed data. Users can now set a default for the preferred option, which can be set in Options/Preferences > Data > Data Import (QM-24722). The option you choose here affects only new models going forward, and earlier models are unaffected. Please read the details about the option behaviors in the Configure Update Options for Import topic.

Users can now disconnect a data import matrix from its data import source, changing the former into a regular matrix containing the last imported data. Access this behavior in the Data Browser's In This Model tab by right clicking the appropriate data import matrix. (QM-24727)

When categories are generated from a field in a data source, by default the category will share the field name. Modelers might change this name to be more friendly for users, but then find it difficult to determine later from which field certain items are sourced. The source field for items is now shown in a tool tip when you hover the cursor over the item of interest while in data import configuration mode. (QM-24725)

For improved usability, Modeler is now more permissive regarding syntax when entering Data Import qualifiers, and errors no longer occur when using single or double quotes, or backslashes (QM-24334)

The script method model.publish.withID, previously deprecated, has now been removed from the scripting API because it is no longer necessary to manually set a model ID (QM-22594). Any scripts that are run containing this method will issue an error message "No signature of method..." and the online Scripting specific documentation explains that "This method has been removed and now throws an error."

The Script Manager pane's help button now links directly to the Scripting help section within the Modeler online help (QM-24535)

These functions have been improved for consistency regarding lists: right(), left(), dollar(), char(), rept(), and text() (QM-24311). They work as they did before, but they handle lists as arguments and they return lists such as for passing to select().

In Constrain Input, expression-based dynamic list constraints now preserve the order of the resulting list provided the sort list in the pop-up option is not selected (QM-24588)

This release includes calculation speed improvements (QM-24718)

Modeler's About Quantrix, accessible from the Modeler Help drop-down menu, now provides a clickable link called Open Source Recognition. Clicking this opens the Quantrix.com page listing the open source projects used by Quantrix (QM-24586)

The DataPush wizard is improved for usability regarding the DataPush log file, which logs information on the success or failure of a DataPush transaction (QM-24558). 
The DataPush logging section in the configure general options dialog lets you choose where to write the .log file. Once you enter a valid name for the .log file name, (for example MyDP.log), radio buttons become enabled allowing you to choose whether to Append to the log file or to Overwrite the log file with each push.

The canvas shape, line and pointer tools have been improved and visually show whether they have been selected on the canvas toolbar (QM-24687). Additionally, the line and shape tools indicate whether they have been double-clicked (meaning that the selected tool remains selected for repeated use on the canvas), by showing a blue border around the selected state.  A related improvement is that ending a line drawing is easier: The line drawing action now ends by clicking on the canvas object to which you want it to connect, or if there is no object attached to the line, double-click on the canvas itself to end the line drawing (QM-24688)

                                   

 

Significant Fixes in Version 22.1.2

An exception no longer occurs related to a timeline with user-labeled quarter items converted to groups (QM-24622)

Summary items, including by quarters-as-groups, can be added to timelines using the Summarization button, or by selecting a quarter group and using Insert > Summary Item (QM-24599)

An exception no longer sometimes occurs when you change time recursion across time or ragged time ranges using configure timeline (QM-24398, F0124727)

To prevent potential conflicts, Timeline categories no longer allow you to drop Data Import grouping levels on them (QM-24298, F0125765). See related Known Issue.

Timelines created with Quarters as Groups, and a recursion formula, that are reconfigured to add a Year category, correctly manage the formulas (QM-24620)

Solver will now complete when you use the Smooth Nonlinear Algorithm with an input cell or cells that are blank or zero (QM-22981, F0099199) 

An exception no longer occurs after editing a Data Import data source when it updates, when there are linked categories (QM-24441)

When updating an Oracle data import where the table name query was created using a SQL statement, an error indicating the table does not exist no longer occurs and the import updates correctly (24686, F0131221)

Cells are no longer cleared in data import matrices when moved and there are no data items in the import (QM-24628, F0130683)

Linked Data Import categories that are no longer attached to a matrix with a Data Source (due to unlinking or matrix deletion) are detached from the data source and changed to regular categories (QM-24612, F0129593)

When updating Data Import in models where a primary data source for a category is no longer in the model, Modeler correctly reconfigures the category and updating Data Import no longer removes items (QM-24664, F0130945)

Groups and items that you manually move to a different location are no longer reordered if you then do an Update Data Import (QM-24440)

In Data Import with live preview off, adding or changing a qualifier no longer causes a connection to the data source (QM-24720)

Exceptions no longer occur in certain circumstances related to data operations, selections, configuring/updating data, adding/removing components and filtering (QM-21013, QM-24028, QM-22947)

An exception no longer occurs when creating a Data Import into an existing matrix where a previous Data Import was rolled back using Undo (QM-24579)

Undo and Update on cell range category item generated items no longer fail to update correctly when the undo is followed by an operation that results in the same items that were undone (QM-24739)

An exception no longer occurs when executing complex category item generation (QM-24589)

An exception related to category item generation no longer occurs, and empty ranges are not saved (QM-24621)

An exception no longer occurs when using right() and left() for empty lists (QM-24311)

Adding a large number of Solver constraints no longer causes an exception (QM-23583)

Using embedded credentials in Credentials Manager, the performWithEmbeddedCredentials script method works for data imports containing categories that are linked to a different data source each with different credentials and an error no longer occurs when an update fails due to needing multiple sets of credentials provided they are properly set up( QM-24547, F0129628)

An exception no longer sometimes occurs in the Script Manager pane when adding and moving Script Libraries containing scripts, then deleting libraries and scripts  (QM-24630, QM-24590)

Scripting now includes read permissions that allow loading scripting code from the scripting library location (QM-24643, F0129995)

An exception no longer sometimes occurs with copy/paste of a canvas in the model browser, or in a canvas involving copy/paste of grouped shapes/text boxes with a line attached that is not part of the group (QM-22080)

An exception no longer sometimes occurs when copying, pasting and deleting canvas objects (QM-21541)

An exception no longer occurs related to editing canvas objects when selecting, and using, the canvas objects pointer tool that becomes visible when you have selected an object but have not yet placed it on the canvas (QM-24669)

An exception no longer occurs when using the Insert Image dialog to insert an image in a cell that already contains an image (QM-24306)

The Model Browser comment box no longer loses focus when you use the font color picker (QM-19467, F0070350)  See related Known Issue on Mac.

Editing a percent-formatted cell by typing a digit or a minus symbol followed by a digit now correctly displays the value as a percentage and automatically inserts a percent symbol after the digit (QM-24511, F0128012)

In the Open View dialog, you can again open a selected view by pressing Enter (QM-24679)

Modeler operations that show an enabled Cancel button (such as in data import connections, publishing, opening/checking out large models, scripted actions/functions), can be canceled using the Cancel button, the "X" button or Escape (QM-24610)

An exception no longer occurs when using the touchpad to select and open the context menu for objects on charts and canvases (QM-22026, QM-22025)

An exception no longer occurs when using the French or Italian languages (via the language packs available at the Quantrix website, https://quantrix.com/language-packs/) with Constrain Inputs (QM-24719). 

All user-facing text should now translate correctly using the language packs (QM-24690)

An exception no longer occurs in Options/Preferences Qloud when entering a URL that does not begin with http or https (QM-24709)

A cell number format entered with more than 2 digits after the decimal point no longer causes the entry to change to 2 digits after the decimal point (QM-24951)

Known Issues in Version 22.1.2

In certain scenarios Data Import and Timeline may conflict such as when you have a data import and timeline quarter category and you try to turn it into a group on a timeline month category. 

You may see multiple login pages appear when you open a local Qloud model and then try to save it (QM-24774)

On MacOS, the Model Browser comment box loses focus when you use the font color picker (QM-24633)

The Safari browser does not connect properly to grant access to Modeler in OAuth, with the result that clicking the Grant Access button on the Authorization page displays an error (QWC-4969). To use Single Sign-on successfully, use Chrome or Firefox as your default browser.