Problem with QAPI and eclipse in Mac OsX

4.52K viewsGeneral Discussion
0

I have been using a Mac with Intel CPU for some days. I installed Eclipse and tried to work on some QAPI projects developed in Windows.
I have checked the Eclipse configuration and it corresponds exactly to what I had in windows.
When I Run | Debug my QAPI project, the console shows the following messages:
2007-02-08 11:56:07.945 java[256] [Java CocoaComponent compatibility mode]: Enabled
2007-02-08 11:56:07.945 java[256] [Java CocoaComponent compatibility mode]: Setting timeout for SWT to 0.100000

then Quantrix is launched and Quantrix splash screen is shown. The Quantrix application hangs on the splash screen (I have to stop debugging in order to clear the splash screen).
I also encounter runtime errors when trying to use my plugins containing user-defined functions that worked under Windows. I am using the latest patch release of Quantrix 2.2
Is there some compatibility issue with Mac-Intel?

Thanks
Luca

0

It turns out there is an issue running a Swing based application (such as Quantrix) from within Eclipse under OSX. This is due to OSX virtual machine’s strict threading requirements for starting up the Swing event loop. This is a known issue with Eclipse and they are working on a fix. In the meantime, we have created a patched version of one of the Eclispe plugins that resolves this issue. Please contact Quantrix support if you’d like a copy of the patched plugin to do Quantrix development under Eclipse on OSX.

Cheers,

pete
peter m. murray

You are viewing 1 out of 7 answers, click here to view all answers.