Problem with QAPI and eclipse in Mac OsX

4.52K viewsGeneral Discussion
0

I have been using a Mac with Intel CPU for some days. I installed Eclipse and tried to work on some QAPI projects developed in Windows.
I have checked the Eclipse configuration and it corresponds exactly to what I had in windows.
When I Run | Debug my QAPI project, the console shows the following messages:
2007-02-08 11:56:07.945 java[256] [Java CocoaComponent compatibility mode]: Enabled
2007-02-08 11:56:07.945 java[256] [Java CocoaComponent compatibility mode]: Setting timeout for SWT to 0.100000

then Quantrix is launched and Quantrix splash screen is shown. The Quantrix application hangs on the splash screen (I have to stop debugging in order to clear the splash screen).
I also encounter runtime errors when trying to use my plugins containing user-defined functions that worked under Windows. I am using the latest patch release of Quantrix 2.2
Is there some compatibility issue with Mac-Intel?

Thanks
Luca

0

Updating this thread in case users have difficulties on Macs in the future…

To run Quantrix from Eclipse on OSX, edit your Run/Debug configuration’s Program Arguments to remove the “-os ${target.os} -ws ${target.ws} -arch ${target.arch} -nl ${target.nl}” parameters. The -ws parameter would force Apple’s Java implementation into SWT compatibility mode which is no longer compatible with Swing-based applications such as Quantrix. (These parameters do not affect the operation of Quantrix and can be removed on other platforms as well.)

Prior to the latest Eclipse release, we had to distribute a patched version of one of the Eclipse plugins to suppress those arguments but this is no longer necessary.

This information has been added to the “Hello World” QAPI Starter document.

You are viewing 1 out of 7 answers, click here to view all answers.