Problem with QAPI and eclipse in Mac OsX

4.16K viewsGeneral Discussion
0

I have been using a Mac with Intel CPU for some days. I installed Eclipse and tried to work on some QAPI projects developed in Windows.
I have checked the Eclipse configuration and it corresponds exactly to what I had in windows.
When I Run | Debug my QAPI project, the console shows the following messages:
2007-02-08 11:56:07.945 java[256] [Java CocoaComponent compatibility mode]: Enabled
2007-02-08 11:56:07.945 java[256] [Java CocoaComponent compatibility mode]: Setting timeout for SWT to 0.100000

then Quantrix is launched and Quantrix splash screen is shown. The Quantrix application hangs on the splash screen (I have to stop debugging in order to clear the splash screen).
I also encounter runtime errors when trying to use my plugins containing user-defined functions that worked under Windows. I am using the latest patch release of Quantrix 2.2
Is there some compatibility issue with Mac-Intel?

Thanks
Luca

0

Sorry, but the problem seems to persist with Quantrix 3.5 and Eclipse 3.5 (Galileo) on a Mac with OS X 10.5.
I followed Brian’s directions, the Program Arguments tetxtarea in the Arguments tab is clean, still when I launch run or debug from Eclipse a loops start. Here is the console trace:
2009-08-15 19:47:33.403 java[356:10b] [Java CocoaComponent compatibility mode]: Enabled
2009-08-15 19:47:33.404 java[356:10b] [Java CocoaComponent compatibility mode]: Setting timeout for SWT to 0.100000
2009-08-15 19:47:38.924 java[356:f203] *** -[NSConditionLock unlock]: lock (<NSConditionLock: 0x13d725d40> ‘(null)’) unlocked when not locked
2009-08-15 19:47:38.951 java[356:f203] *** Break on _NSLockError() to debug.
(etc. etc.)

0

The QAPI Starter Document can be found on the documentation page at this URL:

[url:1f91imhj]http://www.quantrix.com/documentation.htm[/url:1f91imhj]

0

Updating this thread in case users have difficulties on Macs in the future…

To run Quantrix from Eclipse on OSX, edit your Run/Debug configuration’s Program Arguments to remove the “-os ${target.os} -ws ${target.ws} -arch ${target.arch} -nl ${target.nl}” parameters. The -ws parameter would force Apple’s Java implementation into SWT compatibility mode which is no longer compatible with Swing-based applications such as Quantrix. (These parameters do not affect the operation of Quantrix and can be removed on other platforms as well.)

Prior to the latest Eclipse release, we had to distribute a patched version of one of the Eclipse plugins to suppress those arguments but this is no longer necessary.

This information has been added to the “Hello World” QAPI Starter document.

0

It turns out there is an issue running a Swing based application (such as Quantrix) from within Eclipse under OSX. This is due to OSX virtual machine’s strict threading requirements for starting up the Swing event loop. This is a known issue with Eclipse and they are working on a fix. In the meantime, we have created a patched version of one of the Eclispe plugins that resolves this issue. Please contact Quantrix support if you’d like a copy of the patched plugin to do Quantrix development under Eclipse on OSX.

Cheers,

pete
peter m. murray

0

Update: The runtime errors I got from a QAPI fucntion module went away after rebuilding the plugin in Eclipse under MacOs X. The problem with launching the quantrix application via Run | Debug persists.

0

My Eclipse installation uses java 1.5.0 (default with mac osx).
I can run quantrix under mac osx intel out of eclipse, and also your multiview plugin runs smoothly. Apparently, the problem occurs in Eclipse only.
Regards
Luca

0

Hi Luca,

We will have to investigate and let you know. What version of Java are you running with on the Intel based Mac?

If anyone else has had success running Quantrix out of Eclipse on an Intel-based Mac, please feel free to post.

-Mike